android - Android ConstraintLayout向后兼容旧版Android吗?

我正在使用Android Studio 3.5并正在开发必须在Android 4.0及更高版本上运行的新Android App。

我想使用ConstraintLayout。 我的应用程序将与Android 4.0兼容吗?

是它将在4.0上运行, 直到api级别9向后兼容 ,请查看此链接以获取更多信息。

minsdk 取决于所使用的库:

使用支持库 (类为android.support.constraint.ConstraintLayout ),您可以使用:

implementation 'com.android.support.constraint:constraint-layout:1.1.3' --> minSdk=9

使用androidx (类为androidx.constraintlayout.widget.ConstraintLayout ),您可以使用:

implementation "androidx.constraintlayout:constraintlayout:2.0.0-beta2" --> minSdk=14
implementation "androidx.constraintlayout:constraintlayout:1.1.3"  --> minSdk=9

转载请注明来自askonline.tech,本文标题:android - Android ConstraintLayout向后兼容旧版Android吗?


 Top